ports directory (from git fork&clone) up to date, still a warning

Gerben Wierda gerben.wierda at rna.nl
Tue Jan 28 21:29:45 UTC 2020


> On 28 Jan 2020, at 18:31, Ryan Schmidt <ryandesign at macports.org> wrote:
> On Jan 28, 2020, at 10:20, Gerben Wierda wrote:
>> When I work with a cone from my own macports-ports fork, port commands complain about
>> Warning: port definitions are more than two weeks old, consider updating them by running 'port selfupdate'.
>> Even if I have just reset my fork to the current state of the official repo, I still get this.
> This message refers to the portindex file; MacPorts doesn't check anything else. So after you update or reset your fork to the current state, run "sudo portindex" in it. Or run "sudo port sync" which should do that for you after updating your git clone.
>> But if I run ’self update’ my setup gets overwritten with rsync from the official port (I think). I have the feeling I am mixing two ways of updating in an unholy mix.
> "sudo port sync" (and "sudo port selfupdate", which runs "sudo port sync" internally) don't overwrite your setup. They synchronize whichever ports collections you've configured in sources.conf, be they rsync-based, git-based, svn-based, http-file-based, or whatever.
> The one thing that "sudo port sync" does overwrite is any changes you might have made in an rsync- or http-file-based source. But it will not affect any changes you've made in a source that comes from a revision control system like git or svn.

OK. Done that. What does the error mean? I am in a local git branch at the moment (not in master), is that the problem?

bash-3.2# port -v sync
--->  Updating the ports tree
Synchronizing local ports tree from file:///Users/sysbh/MacPortsDev/macports-ports
There is no tracking information for the current branch.
Please specify which branch you want to rebase against.
See git-pull(1) for details.

    git pull <remote> <branch>

If you wish to set tracking information for this branch you can do so with:

    git branch --set-upstream-to=<remote>/<branch> minio-20200128

Command failed: /usr/bin/git pull --rebase --autostash
Exit code: 1
Syncing local Git ports tree failed
Synchronizing local ports tree from rsync://rsync.macports.org/macports/release/tarballs/ports.tar

Willkommen auf dem RSYNC-server auf ftp.fau.de.
Nicht all unsere Mirror sind per rsync verfuegbar.

Welcome to the RSYNC daemon on ftp.fau.de.
Not all of our mirrors are available through rsync.

receiving file list ... done

sent 68 bytes  received 99 bytes  334.00 bytes/sec
total size is 70808576  speedup is 424003.45
Creating port index in /opt/local/var/macports/sources/rsync.macports.org/macports/release/tarballs/ports

Total number of ports parsed:	0 
Ports successfully parsed:	0 
Ports failed:			0 
Up-to-date ports skipped:	22892

port sync failed: Synchronization of 1 source failed

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20200128/0babc39d/attachment.html>

More information about the macports-users mailing list