2nd try, Most recent version of mplayer

dan d. dandunfee at gmail.com
Tue Jul 21 14:19:38 UTC 2020

On Mon, 20 Jul 2020, Ryan Schmidt wrote:

> On Jul 20, 2020, at 00:51, Jeffrey Walton  wrote:
> > On Mon, Jul 20, 2020 at 12:37 AM Ryan Schmidt wrote:
> >
> >> On Jul 19, 2020, at 15:24, dan d. wrote:
> >>
> >>> I tried to install it with the error message:
> >>>
> >>> Error: Failed to install mplayer-devel: no destroot found at:
> >>> /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_multimedia_mplayer-devel/mplayer-devel/work/destroot
> >>
> >> You're probably experiencing this:
> >>
> >> https://trac.macports.org/wiki/ProblemHotlist#nodestrootfound
> >
> > I think that's probably better classified as a UX bug.
> >
> > If MacPorts needs a package cleaned after it is uninstalled, then
> > MacPorts should clean it. There's no sense is pushing the
> > technological debt onto users who do not know how to fix the issue
> > because they lack the problem domain experience.
> >
> > (Or put another way, if this was my project, then I would perform the
> > clean automatically so I don't have to tend to bug reports and mailing
> > list messages about it).
> Sure, we should fix the problem. That's why we have a ticket tracking it. Until we figure out how to fix it, that's why we have a problem hotlist entry to help users work around it.
I used this suggested work around:

port clean --work mplayer-devel>

After getting additional error messages with ways to fix the issue, I finally saw what looks like a typical install of mplayer-devel.

However it doesn't show up in /opt/local/bin nand trying to run it with mplayer-devel produces the bash "no such command"." error message.
There is no man entry either.

I tried uninstalling it, it looked like a typical uninstall. Anew install was typical again, but with the results above as though it did not exist.
Am I missing something obvious in this?



More information about the macports-users mailing list