Issues self updating Macports

Ryan Schmidt ryandesign at
Thu Mar 12 15:35:50 UTC 2020

On Mar 11, 2020, at 18:22, Angus Denton wrote:

> Thanks for your response. I updated Macports with the installer and for the hell of it I ran the selfupdate command. I got the same error, no such directory which I then created with a mkdir.
> Run the selfupdate again and got the no version file error but it made a guess and continued. I have reclaimed and now I am updating outdated. I use sporadically FFMPEG and this is why I have Macports..

Hmm, I don't know why that is happening.

If your /opt/local/var/macports/sources/ directory still contains only a release directory and not a macports directory, then your /opt/local/etc/macports/sources.conf is out of date. As you should every time you update MacPorts base, please compare your sources.conf with your sources.conf.default and adopt any changes from the default into your own (except of course for those changes you made deliberately and want to keep). Do the same for the other conf files in that directory.

You could try deleting the entire directory /opt/local/var/macports/sources/ in case there is somehow something wrong with its contents. Next time you selfupdate or sync, it should repopulate that directory by re-downloading everything that's needed.

> BTW could mac ports co exist with Homebrew as there are packages I am interested in that aren’t available through Macports ?

No, please use only one package manager and uninstall any others and any software you installed with them. They can interfere with one another in unpredictable ways which we do not want to spend our limited time debugging.

More information about the macports-users mailing list