QLColorCode update and issue

Andrew Udvare audvare at gmail.com
Mon Nov 16 08:40:43 UTC 2020

I have a PR here to update the QLColorCode port 
https://github.com/macports/macports-ports/pull/9138 and while 
everything builds, the highlight functionality of this does not work.

One observation: /opt/local/lib/liblua.dylib (port: lua) was installed 
with permissions 0644. I have since fixed this to be 0755 but it has 
made no difference, nor am I sure this is related to the cause.

I get this error from dyld:

Dyld Error Message:
   Library not loaded: /opt/local/lib/liblua.dylib
   Referenced from: /opt/local/bin/highlight
   Reason: no suitable image found.  Did find:
	file system sandbox blocked open() of '/opt/local/lib/liblua.dylib'
	/opt/local/lib/liblua.dylib: stat() failed with errno=1
	file system sandbox blocked open() of '/opt/local/lib/liblua.dylib'

The highlight program itself works fine in CLI, where I have added 
iTerm2 and a number of apps to the Security & Privacy section in System 
Preferences. I added highlight as well to there and it has not changed 
anything. I tried to run `qlmanage -r` (root and non-root) multiple 
times. And lastly I tried rebooting.

Has anyone seen this issue before? And solved it for a port?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_0x1AFD9AFC120C26DD_and_old_rev.asc
Type: application/pgp-keys
Size: 51434 bytes
Desc: not available
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20201116/d82a120b/attachment.key>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_signature
Type: application/pgp-signature
Size: 840 bytes
Desc: OpenPGP digital signature
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20201116/d82a120b/attachment.sig>

More information about the macports-users mailing list