QLColorCode update and issue

Ryan Schmidt ryandesign at macports.org
Mon Nov 16 16:45:19 UTC 2020

On Nov 16, 2020, at 02:40, Andrew Udvare wrote:

> I have a PR here to update the QLColorCode port https://github.com/macports/macports-ports/pull/9138 and while everything builds, the highlight functionality of this does not work.
> One observation: /opt/local/lib/liblua.dylib (port: lua) was installed with permissions 0644. I have since fixed this to be 0755 but it has made no difference, nor am I sure this is related to the cause.

Libraries don't get executed so they don't need the execute bit.

> I get this error from dyld:
> Dyld Error Message:
>  Library not loaded: /opt/local/lib/liblua.dylib
>  Referenced from: /opt/local/bin/highlight
>  Reason: no suitable image found.  Did find:
> 	file system sandbox blocked open() of '/opt/local/lib/liblua.dylib'
> 	/opt/local/lib/liblua.dylib: stat() failed with errno=1
> 	file system sandbox blocked open() of '/opt/local/lib/liblua.dylib'
> The highlight program itself works fine in CLI, where I have added iTerm2 and a number of apps to the Security & Privacy section in System Preferences. I added highlight as well to there and it has not changed anything. I tried to run `qlmanage -r` (root and non-root) multiple times. And lastly I tried rebooting.
> Has anyone seen this issue before? And solved it for a port?

You get this error when doing what?

More information about the macports-users mailing list