ImageMagick port outdated

Ryan Schmidt ryandesign at
Mon Sep 28 05:39:36 UTC 2020

On Sep 27, 2020, at 18:20, Uli Wienands wrote:

> Being curious, and just having received my first .HEIC image ever (form a guy with an iPhone), I upgraded ImageMagic to the present version (worked) and then tried it: It failed. Here are the call & the error message:
> macbook-pro:Pictures uli$ convert IMG_3160.HEIC img_3160.png
> convert: unable to load module `/opt/local/lib/ImageMagick-6.9.11/modules-Q16/coders/': file not found @ error/module.c/OpenModule/1315.
> convert: no decode delegate for this image format `HEIC' @ error/constitute.c/ReadImage/566.
> convert: no images defined `img_3160.png' @ error/convert.c/ConvertImageCommand/3226.
> The weird thing is that /opt/local/lib/ImageMagick-6.9.11/modules-Q16/coders/ actually exists, and so are the four related libraries in /opt/local/bin: /opt/local/lib/libheif.1.dylib /opt/local/lib/libheif.a    /opt/local/lib/libheif.dylib /opt/local/lib/
> So, what could be amiss?

Not sure! I tried converting some heic images now and it worked fine for me on macOS 10.13.6.

What's the contents of /opt/local/lib/ImageMagick-6.9.11/modules-Q16/coders/

Does /opt/local/lib/ImageMagick-6.9.11/modules-Q16/coders/ also exist? What's the output of:

otool -L /opt/local/lib/ImageMagick-6.9.11/modules-Q16/coders/

What OS version are you on? You mentioned /opt/local/lib/ exists. The default behavior for MacPorts is to delete .la files* on OS X 10.9 and later. If you are on 10.8 or earlier, maybe there is a problem specific to older OS versions that we need to investigate. The only reason why you should have /opt/local/lib/ if you're on 10.9 or later is if you edited macports.conf and set "delete_la_files no".

*ImageMagick is an exception. It needs the .la files of its modules for proper operation so they will not be deleted for that port on any OS version.

More information about the macports-users mailing list