Files and Folders access

Lenore Horner lenorehorner at
Thu Dec 16 17:33:08 UTC 2021

I’m still struggling with letting Inkscape (I think Gimp too) installed via MacPorts to be able to open files.  I’ve searched the mailing list archive for the last year for any mention of this and found zip so apparently I’m particularly incompetent.  Here’s what I’ve tried.

Big Sur 11.6
MacPorts base 2.7.1
Just updated the tree and all anything listed as outdated.
inkscape-app @0.92_1, inkscape @0.92.5_9_x11, and xorg-server @1.20.11_1  installed and active
In Apple -> System Preferences -> Security and Privacy -> Files and Folders I cannot do any thing even having unlocked with an admin password.
In Apple -> System Preferences -> Security and Privacy -> Full Disk Access I have given the following access the following:
Inkscape (the terminal app found with Show Contents in the file in my MacPorts folder)
Terminal (the Inkscape icon in the MacPorts folder)

I’ve shut down and restarted the computer and I’m still getting  "Could not read the contents of Desktop” and a parallel complaint for Documents.  I know that a dialog box should pop up asking for my permission to access my Desktop, Documents, etc. folder and that those dialogs not popping up is a known (and unfixible I think) issue.  I thought granting full disk access was the only known work-around, but full disk access to what?   

I have, by the way also tried the dmg from the Inkscape website for version 1.1.1.  I don’t get error messages with it, but it also can’t open a file (spinning beachball of death). So that’s not good either.  

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list