Files and Folders access

Frank Dean frank at
Thu Dec 16 19:58:02 UTC 2021

Lenore Horner <lenorehorner at> writes:

> [1:text/plain Show]
> [2:text/html Hide Save:noname (7kB)]
> I’m still struggling with letting Inkscape (I think Gimp too) installed via MacPorts to be able to open files.  I’ve searched the mailing list archive for the last
> year for any mention of this and found zip so apparently I’m particularly incompetent.  Here’s what I’ve tried.
> Big Sur 11.6
> MacPorts base 2.7.1
> Just updated the tree and all anything listed as outdated.
> inkscape-app @0.92_1, inkscape @0.92.5_9_x11, and xorg-server @1.20.11_1  installed and active
> r
> In Apple -> System Preferences -> Security and Privacy -> Files and Folders I cannot do any thing even having unlocked with an admin password.
> In Apple -> System Preferences -> Security and Privacy -> Full Disk Access I have given the following access the following:
> Inkscape (the terminal app found with Show Contents in the file in my MacPorts folder)
> Xquartz
> Terminal
> (the Inkscape icon in the MacPorts folder)
> I’ve shut down and restarted the computer and I’m still getting  "Could not read the contents of Desktop” and a parallel complaint for Documents.  I know
> that a dialog box should pop up asking for my permission to access my Desktop, Documents, etc. folder and that those dialogs not popping up is a known
> (and unfixible I think) issue.  I thought granting full disk access was the only known work-around, but full disk access to what?   
> I have, by the way also tried the dmg from the Inkscape website for version 1.1.1.  I don’t get error messages with it, but it also can’t open a file (spinning
> beachball of death). So that’s not good either.  
> Thanks,
> Lenore

Hi Lenore,

I don't know if this is the **proper** way to do it, but after running
Inkscape via the launcher, `ps ux | grep -i inkscape` shows Inkscape is
being executed via `/bin/sh`.

Giving `/bin/sh` full disk access allows it to open files in the
Documents folder, but presumably this allows pretty well all
applications to access the entire disk, somewhat subverting the entire
privacy mechanism.  Hopefully, someone knows of a better way.

Similarly, granting the Terminal application access to the Documents
folder allows you to execute the inkscape binary from `/usr/local/bin`
and open documents in the Documents folder, with the advantage of being
able to reduce the scope of access.

All, far from intuitive.



More information about the macports-users mailing list