Files and Folders access

Ian Wadham at
Thu Dec 16 22:58:19 UTC 2021

I have had two similar issues, but with Catalina. One where Gimp (from the Gimp website, not Macports) would not save a file to my Desktop and the other where Apple’’s Screenshot facility (Command-Shift-4) would not save to it, although it had always done so automatically in High Sierra and earlier O/Ss. I got onto Apple Support’s chat line about the first, and they suggested to upgrade my Gimp, which I did and it worked.

The failure to save a screenshot to my Desktop actually occurred during the chat with Apple, but I was unable to investigate at the time. A day later I wanted to take a screenshot and send it by email. Same problem. All the usual Unix permissions on my Desktop seemed fine, but there is a new extension called “” which works some kind of magic (ls - at ld ~/Desktop to see it). Nothing I did at the command-line could fix the problem with my Desktop.

Eventually I found the “approved” method of making my own Desktop accessible to me again.

    1. Bring up a Finder window.
    2. in the left-hand column, right-click on “Desktop” and select “Get Info” from the popup menu.
    3. Scroll to the bottom of the Info window and click on the tiny “lock” icon.
    4. When requested, enter your Admin password.
    5. Click on “+”. A window listing Users and Groups should appear.
    6. Select one (e.g. yourself). This should now appear in the Info window’s list, with Privilege “Read only".
    7. Click on the Privilege and select “Read & Write” from the popup list.
    8. Click on the little “lock” again, to close it.

Not exactly “intuitive”… I would say. Also Apple’s action regarding my Desktop, when it installed Catalina for me, is rather like a builder calling at my house to do some work, then changing the lock on my front door in the process, not telling me about this and then not leaving me a new key. I believe Apple’s intentions are still good, but they are becoming careless of their users’ interests. That works against them because I thought at first that they are becoming like IBM in the "bad old days” of the 60s and 70s. I thought they were trying to “influence" me to use only Apple products on my computer.

Re Gimp, I now have Gimp 2.10.28 from Gimp’s website. It has been upgraded to follow Apple’s latest security protocol. The first time I asked it to save to my Desktop, I got a dialog box asking permission and requiring an Admin password. After that it has been fine and is now on the list of “approved” applications in System Preferences->Security and Privacy->Privacy->Files and Folders.

Hope some of this helps.
Ian Wadham.

> On 17 Dec 2021, at 4:33 am, Lenore Horner <lenorehorner at> wrote:
> I’m still struggling with letting Inkscape (I think Gimp too) installed via MacPorts to be able to open files.  I’ve searched the mailing list archive for the last year for any mention of this and found zip so apparently I’m particularly incompetent.  Here’s what I’ve tried.
> Big Sur 11.6
> MacPorts base 2.7.1
> Just updated the tree and all anything listed as outdated.
> inkscape-app @0.92_1, inkscape @0.92.5_9_x11, and xorg-server @1.20.11_1  installed and active
> r
> In Apple -> System Preferences -> Security and Privacy -> Files and Folders I cannot do any thing even having unlocked with an admin password.
> In Apple -> System Preferences -> Security and Privacy -> Full Disk Access I have given the following access the following:
> Inkscape (the terminal app found with Show Contents in the file in my MacPorts folder)
> Xquartz
> Terminal
> (the Inkscape icon in the MacPorts folder)
> I’ve shut down and restarted the computer and I’m still getting  "Could not read the contents of Desktop” and a parallel complaint for Documents.  I know that a dialog box should pop up asking for my permission to access my Desktop, Documents, etc. folder and that those dialogs not popping up is a known (and unfixible I think) issue.  I thought granting full disk access was the only known work-around, but full disk access to what?   
> I have, by the way also tried the dmg from the Inkscape website for version 1.1.1.  I don’t get error messages with it, but it also can’t open a file (spinning beachball of death). So that’s not good either.  
> Thanks,
> Lenore

More information about the macports-users mailing list