wxMaxima crashes under Big Sur 11.2.1

Ryan Schmidt ryandesign at macports.org
Mon Feb 15 09:16:29 UTC 2021

On Feb 14, 2021, at 10:11, Murray Eisenberg wrote:

> On 14 Feb2021, at 2:12 AM, Ryan Schmidt wrote:
>> On Feb 13, 2021, at 11:33, Murray Eisenberg wrote:
>>> Perhaps this is related to https://trac.macports.org/ticket/61933. 

>> Per the mailing list thread mentioned in that ticket, I think the problem is an install_name_tool bug in Xcode 12.2. I don't know if the problem remains in Xcode 12.4. If you did not build wxWidgets from source, you can try doing that and see if it fixes the problem. Let us know whether or not that fixed it. If 12.4 didn't fix the bug, then a workaround is given in the mailing list thread linked in that ticket.
> (1) There is no port “wxWidgets”, only:
>   wxWidgets-3.0
>   wxWidgets-common
>   wxWidgets_select
> Which one(s) do I need to build from source?

Then I meant wxWidgets-3.0.

> (2) And what about gnuplot, which will break if I uninstall wxWidgets-3.0?

If you try to uninstall a port that other ports depend on, MacPorts won't let you do it. If you force it anyway with the -f flag, then yes, any ports that depend on that port will be broken until you reinstall that port.

You don't have to uninstall wxWidgets-3.0; you can just rebuild it from source.

> (3) Is the build-from-source command “port -s [portname]? 
> 	I’m not finding this documented at https://guide.macports.org.

The -s flag means only allow building from source, not downloading binaries. -b on the other hand means only allow binaries, not building from source. These are documented in https://man.macports.org/port.1.html. The default behavior is to allow both, though you can change it with the buildfromsource setting in macports.conf. This is documented in https://man.macports.org/macports.conf.5.html.

To rebuild [a port that you already have installed] from source, use e.g. sudo port -ns upgrade --force wxWidgets-3.0.

-s means build from source. -n means this port only, not all of its dependencies. --force means "upgrade" anyway even though the port is already up to date.

On Feb 14, 2021, at 11:18, Murray Eisenberg wrote:

> I uninstalled wxWidgets-3.0, gnuplot, maxima, and wxMaxima. Then installed wxWidgets-3.0 from source (port -s install wxWidgets-3.0). Then installed (not from source, but normally) gnuplot, maxima, and wxMaxima. 
> Now I different problem: when I try to open wxMaxima.app, I get a pop-up error: locale ‘pa’ cannot be set.

That's new to me. I guess you should file a bug report.

> If I dismiss that pop-up, then wxMaxima DOES open!

That's good to hear. It suggests that Apple may have fixed the bug in Xcode 12.4. I should try it out on my own system. If they have fixed it, then I should update the macOS Big Sur buildbot worker to Xcode 12.4 and then should revbump wxWidgets-3.0 and any other ports that have been affected by this bug, though it may be difficult to figure out which ports were affected.

More information about the macports-users mailing list