qemu + macOS 11

Sriranga Veeraraghavan sriranga at berkeley.edu
Mon Aug 15 17:18:27 UTC 2022

Hi Mark,

The macports versions of qemu ppc, x86_64, and aarch64 all work for me (at least for OpenBSD & FreeBSD guests) on MacOS 11.6.8 on my M1 Mac.  

I haven’t tried m68k, but the qemu wiki suggests that MacOS may not be fully bootable yet ("Note: Mac OS currently will not fully boot on qemu-system-m68k”), see:

https://wiki.qemu.org/Documentation/Platforms/m68k <https://wiki.qemu.org/Documentation/Platforms/m68k>

But e-maculation.com’s m68k guide suggests that it is possible:

https://www.emaculation.com/doku.php/m68k-qemu-on-osx <https://www.emaculation.com/doku.php/m68k-qemu-on-osx>

You may want to try out the approach suggested on that guide.



> On Aug 15, 2022, at 08:42, Ryan Schmidt <ryandesign at macports.org> wrote:
> On Aug 13, 2022, at 08:43, Mark Brethen wrote:
>> After installing the qemu port on os 11,  I get a blank window when booting macOS, for example:
>> ./qemu-system-m68k -boot d -L pc-bios \
>> -M q800 -m 64 \
>> -serial stdio \
>> -bios Quadra800.rom \
>> -cdrom MacOS8.0.iso
>> I confirmed the iso does work in other emulators. 
> qemu ppc worked fine for me in macOS 11 on Apple Silicon. I didn't test qemu 68k.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20220815/14e901c9/attachment.htm>

More information about the macports-users mailing list