x86_64 version of libncurses

Murray Eisenberg murrayeisenberg at gmail.com
Tue Aug 30 17:24:41 UTC 2022

Under macOS 12.5.1 on an M1 Mac, I'm trying to use the SageMath system (https://www.sagemath.org <https://www.sagemath.org/>) from the command-line in Terminal, and for that libncurses is required. 

Under MacPorts 2.7.2 I have:

	 sudo port installed | grep ncurses
	 ncurses @6.3_0 (active)

And sudo port info ncurses says that it is universal and is for platforms darwin, freebsd.

The SageMath system installed is the arm64 version. However, when I run the sage command, I get error:

[~] % sage
dyld[16273]: Library not loaded: '/opt/local/lib/libncurses.6.dylib'
  Referenced from: '/usr/local/bin/bash'
  Reason: tried: '/opt/local/lib/libncurses.6.dylib' (mach-o file, but is an incompatible architecture (have (arm64), need (x86_64))), '/usr/local/lib/libncurses.6.dylib' (no such file), '/usr/lib/libncurses.6.dylib' (no such file)
/usr/local/bin/sage: line 20: 16273 Abort trap: 6           /usr/bin/env - PATH="$PATH" $MIN_ENV "$SYMLINK"/venv/bin/sage "$@“

Is there some fix from the MacPorts end?

Murray Eisenberg		murrayeisenberg at gmail.com
Mobile (413)-427-5334
503 King Farm Blvd #101		
Rockville, MD 20850-6667	

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20220830/1148cb30/attachment.htm>

More information about the macports-users mailing list