Uninstalling MacPorts on Mac M1 Chip

Lisa Kim lisakimwpg at gmail.com
Wed Jan 12 16:56:36 UTC 2022

It worked!! The “$” was the problem.
Thank you both for your help!!

Have a wonderful day.


From: Jeff Greenberg <listmail.ayendesigns at gmail.com>
Date: Wednesday, January 12, 2022 at 10:52 AM
To: Lisa Kim <lisakimwpg at gmail.com>
Cc: macports-users at lists.macports.org <macports-users at lists.macports.org>
Subject: Re: Uninstalling MacPorts on Mac M1 Chip
Drop the initial $, that’s a prompt and not part of the command

On Jan 12, 2022, at 11:46, Lisa Kim <lisakimwpg at gmail.com> wrote:


I would like to uninstall MacPorts entirely from my Macbook Pro M1. I am currently running MacOS Monterey.
I initially installed MacPorts on my MacBook Air 2011?, but when I bought my new Macbook Pro M1, I transferred all of the files from the old to new computer. As a result, I still have MacPorts on my new mac. I would like to uninstall it entirely.

In an attempt to uninstall MacPorts myself when I first bought the new mac, I may have tried to delete any associated files by searching “MacPorts”. But truthfully, I don’t remember if I had any luck.

I have followed the instructions posted on the guide.macports.org website, but have had no success. The output I receive from the “$ sudo port -fp uninstall installed” input is:

-bash: $: command not found

I have no idea where to go from here. Any help would be appreciated.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20220112/502f3a73/attachment.htm>

More information about the macports-users mailing list