Port tree not syncing

Craig Treleaven ctreleaven at cogeco.ca
Fri Jun 3 01:44:31 UTC 2022


I’m a port maintainer…but I’m having a user problem.  For some weeks now, ‘sudo port selfupdate’ has not been properly updating my local ports tree(s) on my main Mac.  About 2 weeks ago, I was going to post a question about this but then I ran ‘sudo port -d selfupdate’ and it seemed that all the missed updates were now caught up.  I put it down to gremlins in the ether but then I noticed recently that I had no outdated ports when I knew that there should be several.  I tried ’sudo port -d sync’ with the same result, ie no updates.

Obviously, ’sudo port selfupdate’ has worked flawlessly for me for quite a few years.  TTBOMK, I haven’t changed anything relevant on my side.  I’m overdue to update my OS version (I’m on 10.15.7).  

I’ve pasted the debug log from ’sudo port -d sync’ in case that shows something useful:


BTW, I have another older Mac that also has MacPorts installed.  ’sudo port selfupdate’ continues to work as expected on that machine.

Suggestions on what’s wrong and how to fix it?



More information about the macports-users mailing list