Remove "Phantom" Ports

Peter West pbw at
Wed Mar 9 23:42:37 UTC 2022

Have you tried
port reclaim

Peter West
pbw at
“Then the kingdom of heaven will be like ten virgins who took their lamps and went to meet the bridegroom. Five of them were foolish, and five were wise.”

> On 10 Mar 2022, at 9:13 am, James Secan <james.secan at> wrote:
> I have a number of apparently old/replaced ports (p5.26-*) that have been replaced at some point by their p5.28-* updates that are still in some way “alive” on my system.  They show up when I run "port upgrade installed -u outdated” as follows:
> Warning:  No port p5.26-xxxx found in the index
> I’ve tried various ways to get rid of these phantoms, but nothing I’ve tried (like a simple port uninstall) is willing to admit that any p5.26-* ports are around, although a ‘port installed’ command will list all of them and note that they are active.  I am by no stretch an expert in portsmanship, so I could easily be missing some simple answer.
> Thanks.
> Jim
> 3222 NE 89th St
> Seattle, WA 98115
> (206) 430-0109

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list