Remove "Phantom" Ports

James Secan james.secan at
Thu Mar 10 00:57:58 UTC 2022

(Resending, because I didn’t respond to the list)  Just tried, and it listed far too many ports as “Unrequested ports without requested dependents found” along with the p5.26 ports for me to allow the wholesale deletion to go forward.  Looked like most of the ports I have installed.

I decided to go brute force.  I made a list of all p5.26 ports installed and ran through “port unstall” for each one individually.  After running through the list three times I’ve been able to get rid of the whole set.  Hopefully that hasn’t broken anything.

3222 NE 89th St
Seattle, WA 98115
(206) 430-0109

> On Mar 9, 2022, at 3:42 PM, Peter West <pbw at> wrote:
> Have you tried
> port reclaim
> ?
>> Peter West
> pbw at
> “Then the kingdom of heaven will be like ten virgins who took their lamps and went to meet the bridegroom. Five of them were foolish, and five were wise.”
>> On 10 Mar 2022, at 9:13 am, James Secan <james.secan at> wrote:
>> I have a number of apparently old/replaced ports (p5.26-*) that have been replaced at some point by their p5.28-* updates that are still in some way “alive” on my system.  They show up when I run "port upgrade installed -u outdated” as follows:
>> Warning:  No port p5.26-xxxx found in the index
>> I’ve tried various ways to get rid of these phantoms, but nothing I’ve tried (like a simple port uninstall) is willing to admit that any p5.26-* ports are around, although a ‘port installed’ command will list all of them and note that they are active.  I am by no stretch an expert in portsmanship, so I could easily be missing some simple answer.
>> Thanks.
>> Jim
>> 3222 NE 89th St
>> Seattle, WA 98115
>> (206) 430-0109

More information about the macports-users mailing list