update and gimp

Riccardo Mottola riccardo.mottola at libero.it
Mon Oct 10 22:44:15 UTC 2022

Hi James,

James wrote:
> I installed Gimp, but had no joy with 'open with ...'
> Ryan explained how the system worked.
> Eventually I un-installed the macports version, installed Gimp's dmg and for ages everything 'just worked'
> I'm a believer in 'if it aint broke, don't fix it'. Time passed and all was well.
> Eventually I was persuaded to selfupdate and update outdated.
> My gimp dmg was removed !! the macports version was re-installed !! together with the broken 'open with ...' behavior.

The two gimps are installed indifferent positions, one is in 
Applications one is inside Application/MacPorts, so they don't mess up 
with and they can even co-exist. I think something different happend.

> Can anyone tell me what I must have done to achive this, certainly nothing deliberate.
> A comment for Ricardo, I spend 1/2 my day working at NOT the keyboard/console of TheMachineImWorkingOn so X11 is important. Remote Desktop is plain horrid, nomachine is better but straight X11 is by far the nicest.

Are you referring to me?
I don't use X11 for gimp on mac, but am avid quartz/aqua user and on the 
older setup I am running, "Open As..." does work and integrates, as does 
The only caveat is  that, apparently due to my old MacOS version, the 
first opened image gets opened twice.


More information about the macports-users mailing list