clamav-server configuration

Lenore Horner lenorehorner at
Mon Sep 12 22:50:03 UTC 2022

Thanks Steve. The problem turned out to be that I had run 
open -a Automator ~/Library/Services/ClamavScanIt.workflow && osascript -e 'quit app "Automator"'
from someplace other than my home directory.  The copy command worked, but the workflow didn't.  I think port commands do the same thing (not run complaining about lack of existence or permissions) when I don't pay attention and try to run from somewhere like my homework assignments folder.  Remembering to do cd and then running the open worked fine.

> On Sep 10, 2022, at 08:36, Steven Smith <steve.t.smith at> wrote:
> Thanks I’m the author.
> It appears that this is unrelated to the port and that there’s some issue with your home directory or account setup.
> In Unix, the path ‘~’ is a synonym refers to your home directory, typically ‘/Users/MyUserName’, and you definitely should be able to copy stuff there.
> If it were me, I’d try to troubleshoot with a few simple commands like:
> cd ~
> ls ~
> ls -ld ~
> ls -ld ~/Library/Services/ClamavScanIt.workflow
> If any of that fails, you have bigger issue and should figure out why the path ~ or equivalently (default account configuration) /Users/MyUserName doesn’t exist.
> If it works, then there’s some subtler issue with the ‘open’ command.
>> On Aug 28, 2022, at 11:23, Lenore Horner <LenoreHorner at> wrote:
>> Clamav-server has a really nice set of notes at the end about how to set it up.  Thank you to the folks who set that up.
>> I was following those instructions and got to the part 
>>> Clamav Scan-On-Demand is performed with the command:
>>>             /opt/local/bin/ file1 [directory1] [file2 ...]
>>>         A Contextual Menu applies to the selected
>>>         items in Add this menu item with the command:
>>>             cp -R /opt/local/share/clamav/ClamavScanIt.workflow
>>>     ~/Library/Services
>>>             open -a Automator ~/Library/Services/ClamavScanIt.workflow \
>>>       && osascript -e 'quit app "Automator"'
>> But when I ran the automator command on my Monterey system the following happened.  
>> open -a Automator ~/Library/Services/ClamavScanIt.workflow \ && osascript -e 'quit app "Automator"'
>> The file /Users/MyUserName/  does not exist.
>> I substituted MyUserName for my actual username which was correct in the actual results from running the command.
>> ClamavScanIt.workflow is a directory which contains solely the directory Content which contains Info.plist, Resources, QuickLook, document.wflow.
>> I can go into Automater and open ClamavScanIt.workflow.  I can also find ClamavScanIt in services in the finder and can select it.  Nothing obvious happened when I did so I don't actually know if it's working.  Did the command actually fail?  Why is it complaining about the non-existence of a directory which is very much alive and well?
>> Thanks,
>> Lenore

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list