Subversion repo issue

Ryan Schmidt ryandesign at
Tue Jun 5 08:57:55 PDT 2007

On Jun 5, 2007, at 10:45, Mark Grimes wrote:

> Here's one I've never seen before... anyone else having trouble with
> the MP repo?  Now svk does apply props for merge tickets as mentioned
> prior, and this has always worked before...
> I suppose I could one-off these commits until I narrow down the
> problem, but wanted to ask here at the sake of multiple commits per
> single functional change (email obscurity in this case).
> ===> Auto-merging (25942, 25943) /local/trunk to /mirror/trunk (base
> /mirror/trunk:25941).
> Merging back to mirror source
> U   dports/net/libdnet/Portfile
> U   dports/perl/p5-xml-apachefop/Portfile
> U   dports/perl/p5-params-util/Portfile
> U   dports/perl/p5-java/Portfile
> U   dports/perl/p5-path-class/Portfile
> U   dports/perl/p5-app-cli/Portfile
> U   dports/perl/p5-pdf-reuse/Portfile
> U   dports/perl/p5-list-moreutils/Portfile
> U   dports/security/ike-scan/Portfile
> U   dports/security/metasploit3/Portfile
> New merge ticket:
> e4b2a6a8-e742-4924-8f8a-3771363e925e:/local/trunk:25943
> Failed to execute WebDAV PROPPATCH: At least one property change
> failed; repository is unchanged

I had to obscurify my ports in two commits because it wouldn't go in  
one. I frequently have this problem with commits which span many  
files. I don't use svk, I just use plain svn. I get a message about  
the SSL somethingorother. Oh, wait, here, I still have it:

Transmitting file data ........................svn: Commit failed  
(details follow):
svn: PUT of '/repository/macports/!svn/wrk/55dfb2b4-ae74-47ff-b412- 
db15fdc83ddd/trunk/dports/sysutils/cronolog/Portfile': SSL  
negotiation failed: SSL error: sslv3 alert bad record mac (https://

In my case, I tried many times and it was always sysutils/cronolog/ 
Portfile that was mentioned.

More information about the macports-dev mailing list