[MacPorts] #10682: BUG: New Install Won't Work on MBP (Problem with Pextli

Mark Duling mark.duling at biola.edu
Tue Mar 13 18:00:02 PDT 2007

When you say "installed Aqua/Tk", do you mean this? 
http://tcltkaqua.sourceforge.net/  If there are good reasons to do install
this package (isn't it kinda old?), then we have a known issue that could
be written up on the Wiki.  Also, there is a problem with MacPorts Tk
+aqua variant.  http://trac.macports.org/projects/macports/ticket/8730  Is
using MacPorts Tk +aqua a good idea?  If a small blurb could be
constructed to generalize whats going on with Tk and aqua in general for
MacPorts users, I'd put it on the Wiki.


noreply at macosforge.org on Tuesday, March 13, 2007 at 4:40 PM -0800 wrote:
>My problem was related to issue
> [http://trac.macports.org/projects/macports/ticket/11401 11401]. Below is
> the assistance I got on #macports which solved my problem.
> {{{
> [8:06pm] mrevoir: I've been having problems on my MacBook Pro ever since
> did a self update to 1.3.1 with "Failed to initialize ports system, can't
> find package Pextlib 1.0". I was able to extract that file from the
> as suggested in the mailing list, but then I was unable to build most
> packages due to vm_allocate errors. I tried installing MacPorts
> but it too can't find Pextlib, even though pkgIndex.tcl and Pextlib.dylib
> are in /opt/local/share/darwinports/Tcl/pextlib1.0/. Does anyone have any
> suggestions? I've tried both DarwinPorts 1.2.1 and 1.3.1 from the
> installers.
> [8:24pm] Eridius: mrevoir: I bet you have the same problem someone else
> did
> [8:24pm] Eridius: you installed Aqua/tk didn't you?
> [8:24pm] Eridius: apparently it's not generating the package index for
> pextlib properly (if you examine it, it just contains comments)
> [8:24pm] Eridius: the trick is to uninstall Aqua/tk, rename
> /usr/bin/tclsh8.4.7 to tclsh8.4 (not necessary, but that's what the
> provided one looks like), and symlink /usr/bin/tclsh to it
> [8:25pm] mrevoir: Eridius: Thanks, I'll give that a shot.
> [8:38pm] mrevoir: Eridius: You're correct that the package index was
> empty. I have 8.4, 8.4.7 and 8.5 installed. tclsh was symlinked to
> tclsh8.4. Symlinking it  to 8.4.7  made it work. Thanks!
> }}}

More information about the macports-dev mailing list