gcr requires gtk to be installed with +x11

David Evans devans at macports.org
Mon Oct 10 13:02:12 PDT 2016

On 10/10/16 10:58 AM, Johannes Kastl wrote:
> On 09.10.16 10:24 Johannes Kastl wrote:
>>> --->  Computing dependencies for gcr --->  Fetching archive
>>> for gcr Error: org.macports.archivefetch for port gcr returned:
>>> gtk3 must be installed with +x11.
> I still get the same error, so I guess it has not been a temporary
> failure.
> Is there a way to get gimp2+quartz to build without having to
> install all of x11?
> And: Why has this changed suddenly? What made gimp2 require gcr? Or
> what made gcr require gtk3+x11 as dependency?

Again, mea culpa.  I added epiphany as a dependency for gimp2.  I removed
that dependency because epiphany doesn't build +quartz, just +x11.

gcr is a dependency of epiphany and it too only builds +x11.  But you don't
need it any more because gimp2 no longer depends on epiphany.  So get rid of
it and don't try to build it.

A clean build of gimp2 +quartz and its dependencies builds and works fine for
me.  As I recommended before, to do a clean build of gimp2 without problems
from any spurious +x11 ports that are lying around, do this:

sudo port deactivate active
sudo port install gimp2 +quartz

Hope this helps

More information about the macports-dev mailing list