[MacPorts] #58796: Problem installing py27-pymvpa

MacPorts noreply at macports.org
Wed Aug 7 01:47:23 UTC 2019

#58796: Problem installing py27-pymvpa
  Reporter:  NicoleEic  |      Owner:  stromnov
      Type:  defect     |     Status:  assigned
  Priority:  Normal     |  Milestone:
 Component:  ports      |    Version:  2.5.4
Resolution:             |   Keywords:
      Port:  py-pymvpa  |

Comment (by NicoleEic):


 thank you very much for looking into this. I tried the install swig using
 the suggested command, but it didn't change the error message in the
 terminal. Then I ran the following lines, which were executed without

 $ port clean --all py27-pymvpa

 $ sudo port install swig-python
 --->  Computing dependencies for swig-python
 --->  Cleaning swig-python
 --->  Scanning binaries for linking errors
 --->  No broken files found.
 --->  No broken ports found.

 # recommended installation command from the pymvpa website:
 sudo port install py27-pymvpa +scipy +nibabel +hcluster +libsvm
 +matplotlib +pywavelet
 --->  Computing dependencies for py27-pymvpa
 --->  Cleaning py27-pymvpa
 --->  Scanning binaries for linking errors
 --->  No broken files found.
 --->  No broken ports found.

 sudo port select python python27-apple

 However, the module was still not available to import for python:

 $ python
 Python 2.7.10 (default, Feb 22 2019, 21:55:15)
 [GCC 4.2.1 Compatible Apple LLVM 10.0.1 (clang-1001.0.37.14)] on darwin
 Type "help", "copyright", "credits" or "license" for more information.
 >>> import mvpa2
 Traceback (most recent call last):
   File "<stdin>", line 1, in <module>
 ImportError: No module named mvpa2

 On the other hand, the issue does not occur with the py35-pymvpa port,
 which allows me to import the module:

 $ sudo port install py35-pymvpa +scipy +nibabel +hcluster +libsvm
 +matplotlib +pywavelet
 --->  Computing dependencies for py35-pymvpa
 The following dependencies will be installed:
 Continue? [Y/n]: y
 --->  Fetching archive for python35
 --->  Attempting to fetch python35-3.5.7_0.darwin_18.x86_64.tbz2 from
 --->  Attempting to fetch python35-3.5.7_0.darwin_18.x86_64.tbz2.rmd160
 from http://ywg.ca.packages.macports.org/mirror/macports/packages/python35
 --->  Installing python35 @3.5.7_0
 --->  Activating python35 @3.5.7_0
 --->  Cleaning python35
 --->  Fetching archive for py35-cython

 $ sudo port select --set python python35
 $ sudo port select --set python3 python35

 $ python
 Python 3.5.7 (default, Mar 19 2019, 03:20:27)
 [GCC 4.2.1 Compatible Apple LLVM 10.0.0 (clang-1000.11.45.5)] on darwin
 Type "help", "copyright", "credits" or "license" for more information.
 >>> import mvpa2


 It seems I can use the module now, but I'd prefer the python27 version,
 which is supposedly more robust. Do you have any suggestion of what I can
 change about the installation command? Will any other log-outputs be
 helpful for you?

 Thank you very much and kind regards,

Ticket URL: <https://trac.macports.org/ticket/58796#comment:3>
MacPorts <https://www.macports.org/>
Ports system for macOS

More information about the macports-tickets mailing list