question about upgrading port (getting errors)

Evan Burrows eburrows at
Sat Jun 2 12:01:44 PDT 2007

No, before now I have never had a need to uninstall a port so I haven't
tried but when I tried to uninstall pcre, expat, etc like you said before I
get the same problem about it not understanding the uninstall command.

$ ls -ll /opt/local/bin/port
-r-xr-xr-x   1 root  admin  68240 Jun  2 05:03 /opt/local/bin/port

I will take a look at the port file you sent me but I don't really know what
to look for in terms of differences between mine and yours.  I have never
had a reason to edit the port command but I guess it is possible something
happened to it.  I guess you may be right and I might need to start from
scratch.  It is just frustrating since this isn't the first time I would
have had to completely reinstall macports (well I had darwinports and that
had issues so I did a fresh install of macports a few months back).  It is
possible it is user error and that I am doing something wrong but I don't
really use it all that often and have only installed like 10 apps since I
originally installed darwinports a year and a half ago.

I'll take a look at your file and try to see if anything strikes me as
blatantly obvious.


On 6/2/07, Jyrki Wahlstedt <jwa at> wrote:
> On 2.6.2007, at 21.07, Evan Burrows wrote:
> > The problem is that it refuses to recognize the uninstall command.
> > I don't
> > really want to go through the hassle of reinstalling macports
> > because I have
> > other ports installed on my machine and I don't want to have to
> > wait until
> > sometime tomorrow for everything to finish compiling. But if that
> > is the
> > only way to fix this php and uninstall issue then I guess that is
> > what I
> > will have to do.
> >
> > $ sudo /opt/local/bin/port -f uninstall pcre @4.5_0
> >
> > Password:
> > Error: port uninstall failed: invalid command name
> > "portuninstall::uninstall"
> >
> > I am really sorry for taking up so much of your time but I
> > appreciate the
> > help.
> >
> > thanks,
> > Evan
> >
> Well,
> the only problem here is that your problem isn't solved. Have you
> been able to uninstall anything else? What is the info of your port.
> Mine is:
> jwa at lan3:conf> ll /opt/local/bin/port
> -r-xr-xr-x   1 root  admin  68240 17 Tou 18:27 /opt/local/bin/port*
> (Tou comes from toukokuu, May in Finnish)
> I'll attach that here, you could compare.
> !
> ! Jyrki Wahlstedt
> !       skype:jyrkiwahlstedt
> !
> !
> ! Our life is no dream; but it ought to become one and perhaps will.
> ! PGP key ID: 0x139CC386 fingerprint: F355 B46F 026C B8C1 89C0  A780
> 6366 EFD9 139C C386
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the macports-users mailing list