question about upgrading port (getting errors)

Ryan Schmidt ryandesign at
Sun Jun 3 22:16:29 PDT 2007

On Jun 2, 2007, at 14:01, Evan Burrows wrote:

> No, before now I have never had a need to uninstall a port so I  
> haven't tried but when I tried to uninstall pcre, expat, etc like  
> you said before I get the same problem about it not understanding  
> the uninstall command.

I also can't explain why your MacPorts wouldn't be recognizing the  
uninstall command. It sounds like "something" is messed up with your  
base MacPorts installation, though I don't know much about the base  
code and so couldn't speculate as to what.

Fortunately, I think you can safely reinstall MacPorts base without  
affecting any of your installed ports. Download the 1.4.0 disk image  
(the correct one for your OS version) and run the installer package  
on it.

Then, "sudo port selfupdate" to update you to MacPorts 1.4.42 again.  
(I'd refer you to download 1.4.42 directly, except that we only make  
direct downloads of the major versions available.)

I'm not confident that this will fix it... I'm also not 100% sure  
this won't mess up your installed ports. But I *think* it won't.

More information about the macports-users mailing list