libtool woes

Ryan Schmidt ryandesign at
Mon Feb 4 04:49:27 PST 2008

On Feb 4, 2008, at 02:02, David Epstein wrote:

> Paul Beard-2 wrote:
>> I am trying this regime:
>> sudo port -f uninstall libtool
>> sudo port -f uninstall apr
>> sudo port install libtool
>> sudo port install apr
>> sudo port clean apache2
>> sudo port upgrade apache2
>> port -f overrides any complaints
> This worked for me on Mac Os X 10.4.11, MacPorts 1.600.
> I include the initial response of port, which shows something, I'm  
> not sure
> what.
> When I originally tried to install apache2, port made no attempt to  
> install
> libtool.
> Isn't this surprising in view of the first line of the log below?
> So it seems that apache2 does not list its dependencies correctly,  
> which
> would explain
> why everything is fine for some users but not for others. Or maybe the
> problem is that there are different versions of libtool, as mentioned
> previously in
> this thread---I'm not sure if this makes sense.
> Anyway, here is the initial output from Paul Beard's commands:
> Error: port uninstall failed: Registry error: libtool not registered
> as installed.
> --->  Unable to uninstall apr 1.2.11_0, the following ports depend on
> it:
> --->    apr-util
> --->    subversion
> Warning: Uninstall forced.  Proceeding despite dependencies.
> --->  Deactivating apr 1.2.11_0
> --->  Uninstalling apr 1.2.11_0
> --->  Fetching libtool
> --->  Attempting to fetch libtool-1.5.24.tar.gz
> from
> --->  Verifying checksum(s) for libtool
> --->  Extracting libtool
> --->  Configuring libtool--->  Building libtool with target all
> --->  Staging libtool into destroot
> --->  Installing libtool 1.5.24_1
> --->  Activating libtool 1.5.24_1--->  Cleaning libtool

So based on the fact that you experienced the error without libtool  
installed, and that Peter O'Gorman says it may be that apr was built  
before MacPorts 1.6 was released, it sounds like maybe apr, and not  
libtool, was the problem. I originally suggested that one or the  
other of those ports was the problem but I have yet to hear anyone  
definitively say which one it is. Simply force-upgrading both doesn't  
help us isolate the problem. :)

I note that in your output above, you're uninstalling apr 1.2.11_0.  
That's an old version anyway. The current version is 1.2.12_0. So you  
should try uninstalling libtool, then upgrading apr, then see if it  

More information about the macports-users mailing list