Macports X11 damaged?

ggrubbish at ggrubbish at
Mon Apr 6 15:11:11 PDT 2009

Am Montag, 6. April 2009 schrieben Sie:
> On Apr 2, 2009, at 10:48, ggrubbish at wrote:
> > I'm completely new to macports, but have experience with linux
> > debian distributions. I installed and updated apple X11 on a PPC
> > 10.4.11.
> Welcome to MacPorts! I'll try to answer your questions below.
Hi Ryan, thank you for diggin in this issue!
> The preferred way to use MacPorts with X11 apps now is to use the
> xorg ports that come with MacPorts. You don't need to do anything
> special to get these; simply installing the port you want will cause
> the required xorg ports to be installed as well.
That's the probnlem I guess. I installed macports following the wiki 
guide and therefore installed the Apple x11 server.
But now the preferred way to install x11 apps is xorg-server, because 
apples xserver is a bit outdated, right? As I understand some 
application doesn't build no more against the apple x11 in ppc. Maybe 
like I experienced with xpdf.
> > e.g.:
> >
> > [16:36:58] [user at mac :~]$ > xdvi &
> > [1] 11376
> > [16:37:04] [user at mac :~]$ > dyld: Library not loaded: /opt/local/
> > lib/libXaw.7.dylib
> >   Referenced from: /opt/local/bin/xdvi-xaw.bin
> >   Reason: image not found
> >
> > [1]+  Trace/BPT trap          xdvi
> Does /opt/local/lib/libXaw.7.dylib exist on your hard drive? It
> should. If it does not, is the xorg-libXaw port installed? It should
> be, since xdvi is part of the texlive_base port which declares a
> dependency on the xorg-libXaw port. You could try rebuild the xorg-
> libXaw port:
> sudo port -nf upgrade xorg-libXaw
Yes I think everything is installed, but in the wrong path (apple x11 

> >     A workaround is to add +system_x11 to /opt/local/etc/macports/
> > variants.conf, so that by default the system X11 libraries (instead
> > of the MacPorts libraries) are used.
> > [...]
> I personally would not recommend using the +system_x11 variant. I
> have not tried it myself. Note the advice from our X11 expert Jeremy:
> "Also note that adding or removing +system_x11 variant should be done
> with caution and switching between these variants is not supported.
> You should do a complete rebuild of all ports that use X11 if you
> change between those variants if you want a usable system"
> He provides instructions for doing that.
This didn't worked for me, because of the lack of e.g. x11 and xext and 
so on. They were installed, but port didn't find them during 
configuration of the packages.
> > This resulted in some errors:
> > e.g.:
> > _XFreePixmap referenced from libtk8 expected to be defined in /opt/
> > local/lib/libX11.6.dylib
> > collect2: ld returned 1 exit status
> > make: *** [wish] Error 1
> >
> > Full report here:
> >
> > Then I got this error:
> >
> > $ > dyld: Library not loaded: /opt/local/lib/libXt.6.dylib
> >   Referenced from: /opt/local/bin/xpdf
> >   Reason: image not found
> >
> >
> > 006989.html
> I don't know specifically what's going on here but would first try
> rebuilding the affected ports.
/opt/local/lib/libX11.6.dylib isn't there as expected, but 
under /usr/X11R6/.

> > I got also errors on sudo port install xorg-server:
> >
> > checking for XLIB... configure: error: Package requirements (x11)
> > were not met:
> >
> > No package 'x11' found
It asks for the package x11
> > Consider adjusting the PKG_CONFIG_PATH environment variable if you
> > installed software in a non-standard prefix.
> >
> > Alternatively, you may set the environment variables XLIB_CFLAGS
> > and XLIB_LIBS to avoid the need to call pkg-config.
> > See the pkg-config man page for more details.
> This is mostly the same stuff, configure scripts not finding the
> dependencies, but I don't know why.
> > sudo port install x11 doesn't work either:
> >
> > $ > sudo port install x11
> > Password:
> > Error: Port x11 not found
> >
> > What's wrong?
> There is no port called "x11". There is a port "xorg-libX11"; perhaps
> that's what you meant.
No, port itself or the configured package meant that, not me. But 
because of these errormessages I tried that nevertheless.

Here a translated Message with additional Informations I wrote in a 
german mac forum (without any answer):

In the first place I setup the xserver from apple, and had build 
successfully a working macports x11 environment.

Then I tried to install and run xpdf. It installed fine but didn't run. 
I think I confused the installation by following the workaround to add 
+system_x11 to the variants.conf. I guess port searches now in the 
wrong path and messed up some dependencies.

How can I switch in this situation successfuly to   xorg-server and use 
it over apples x11?

The apple xserver under Tiger is a bit outdated isn't it?Some apps won't 
compile against the apple x11 under PPC.
"Yes, this is expected behaviour. X had historically been an exception 
the "MacPorts uses its own stuff" rule, for various reasons. Those
reasons no longer apply, so the exception is gone.

If you really want the old behaviour back, you can use the +system_x11
variant (best to add it to variants.conf)."

I'm afraid, that it wasn't that  good to follow that workaround... 

The List of installed packages:

If I start apples X11 (You can see the different path to X):

$ > /usr/X11R6/bin/X

XFree86 Version 4.4.0 / X Window System
(protocol Version 11, revision 0, vendor release 6600)
[DRI] screen 0 installation complete
Screen 0 added: 1600x1200 @ (0,0)
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing 
from list!

Quitting XDarwin...

It won't start by startx due to the wrong searchpath:
$ > startx

bootstrap_look_up(): 1102l
font_cache: Scanning user font directories to generate X11 font caches
font_cache: Updating FC cache
xauth:  creating new authority file /Users/michels/.serverauth.13833

xinit:  No such file or directory (errno 2):  no 
server "/opt/local/bin/X" in PATH

Use the -- option, or make sure that /opt/local/bin is in your path and
that "/opt/local/bin/X" is a program or a link to the right type of 
for your display.  Possible server names include:

    Xorg        Common X server for most displays
    Xquartz     Mac OSX Quartz displays.
    Xvfb        Virtual frame buffer
    Xfake       kdrive-based virtual frame buffer
    Xnest       X server nested in a window on another X server
    Xephyr      kdrive-based nested X server

font_cache: Done
giving up.
xinit:  No such file or directory (errno 2):  unable to connect to X 
xinit:  No such process (errno 3):  Server error.

I'm not able to install xorg-libX11 because it's already active (!):

$ > sudo port install xorg-libX11
--->  Fetching xorg-libX11
--->  Attempting to fetch libX11-1.2.tar.bz2 from
--->  Verifying checksum(s) for xorg-libX11
--->  Extracting xorg-libX11
--->  Configuring xorg-libX11
--->  Building xorg-libX11
--->  Staging xorg-libX11 into destroot
--->  Installing xorg-libX11 @1.2_0
--->  Activating xorg-libX11 @1.2_0
Error: Target org.macports.activate returned: Image error: Another 
version of this port (xorg-libX11 @1.2_0+system_x11) is already active.
Error: Status 1 encountered during processing.

I'm not able to install xorg-server because x11 is not found:

$ > sudo port install xorg-server
--->  Configuring xorg-server
Error: Target org.macports.configure returned: configure failure: shell 
command " 
cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_xorg-server/work/xorg-server-1.4.2-apple40" 
&& ./configure --prefix=/opt/local --with-mesa-source=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_xorg-server/work/xorg-server-1.4.2-apple40/../Mesa-7.0.4 --with-apple-applications-dir=/Applications/MacPorts --with-fontdir=/opt/local/share/fonts --with-apple-application-id=org.macports.X11 " 
returned error 1
Command output: checking for library containing gethostbyname... none 
checking for main in -lws2_32... no
checking for getaddrinfo... yes
checking if IPv6 support should be built... yes
checking for struct sockaddr_in.sin_len... yes
checking for socklen_t... yes
checking if Xtrans should support os-specific local connections... no
checking for authdes_seccreate... no
checking for authdes_create... no
checking if Secure RPC authentication ("SUN-DES-1") should be 
supported... no
checking for /opt/local/share/sgml/X11/defs.ent... no
checking for linuxdoc... no
checking for ps2pdf... /opt/local/bin/ps2pdf
checking Whether to build documentation... no
checking Whether to build pdf documentation... yes
checking whether to build Xquartz... yes
checking for PIXMAN... yes
checking for DBUS... no
checking for HAL... no
checking for XLIB... configure: error: Package requirements (x11) were 
not met:

No package 'x11' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XLIB_CFLAGS
and XLIB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Error: Status 1 encountered during processing.

If I try to upgrade outdated I get this:

The programs and configure scripts are searching X 
in /opt/local/bin/X, /opt/local but it resides (apples) in /usr/X11R6/

How can I adjust this, and fix my ports installation to use the newest 

Thank you in advance!

Kind regards


More information about the macports-users mailing list