Problem installing KDE/Amarok

Ryan Schmidt ryandesign at
Thu Jun 25 20:49:11 PDT 2009

On Jun 25, 2009, at 22:38, Hal Vaughan wrote:

> On Jun 24, 2009, at 6:02 PM, Ryan Schmidt wrote:
>> On Jun 24, 2009, at 16:47, Hal Vaughan wrote:
>>> I figured they'd be lost if I had to kill the terminal.  Of  
>>> course, I'm not 100% sure that this is the issue.  For all I  
>>> know, the process could have been okay and it could be something  
>>> else that crashed it.  (Come to think of it, there was an ssh  
>>> connection, but it's a program I'm always running in the b.g.)  I  
>>> figure in worst case, since it's the first thing I'm installing,  
>>> I could wipe out any KDE directory in Applications and just wipe  
>>> all of /opt, reinstall MacPorts and restart.
>>> Is there any place else KDE would store files that I'd have to  
>>> clear out if I do that?
>>>> After restarting Terminal or the computer, you can try again.  
>>>> You can use the "-d" flag ("port -d install amarok") to get a  
>>>> lot more information printed out. This will let you see what  
>>>> exactly a port was doing if and when it gets hung up. On the  
>>>> other hand, the vast quantity of output you will get means you  
>>>> will very likely miss any "you must do this after installing the  
>>>> port"-type messages that some ports print.
>>> I was also going to see if I could find a list somewhere of all  
>>> the messages from KDE.  It looks like each package is giving me  
>>> the same message at the start and the end.
>>> I'll most likely wipe out /opt and just start clean, since I  
>>> don't have any other packages done with MacPorts yet.  I don't  
>>> mind letting it rebuild qt overnight.
>> If you want to do that, you should follow the uninstall  
>> instructions shown here:
> As noted elsewhere, I went on with the install and eventually  
> (after fixing the svn issue - thanks, Ryan!), I'm dealing with a  
> problem I think is related to this issue.  After it was all  
> installed properly, I ran the following commands:
> sudo chown -R $USER ~/Library/Preferences/KDE
> open /Applications/MacPorts/KDE4/
> launchctl load /Library/LaunchAgents/org.freedesktop.dbus- 
> session.plist
> The first two were the instructions given at the start of most  
> packages as they were installed and the last one was given at the  
> end.  When I ran the last one, I got this:
> nothing found to load
> I suspect that when my terminal locked up previously, there were  
> some messages on what to run that I didn't get to see.  Is there a  
> resource somewhere that would give me an output of that install  
> command or a list of command lines I have to run after KDE is  
> installed?
> Also, would I have to run the last 2 commands each time my iMac  
> boots or is it like some Linux systems -- that once a service is  
> running, it restarts on boot until a user stops it?

I'll let someone else answer what is required to get KDE to run. I  
don't know.

"chown" would permanently set the ownership; it won't get unset.

"open" is the same as double-clicking something in the Finder.

"launchctl load -w" loads a service and tells it to launch at every  
system startup. "launchctl unload -w" unloads a service and tells it  
not to load at every system startup. If you don't use the "-w"  
option, then the service is started or stopped, but nothing is  
changed about what happens at system startup.

More information about the macports-users mailing list