Re: GMP and MPFR fails

Vincent DIEMUNSCH vincent.diemunsch at
Tue May 4 13:17:45 PDT 2010

Thanks Ryan for your help !

The tests seem to pass. For instance for MPFR :
DEBUG: No need to upgrade! gmp 5.0.1_0 >= gmp 5.0.1_0
--->  Computing dependencies for mpfr
DEBUG: Searching for dependency: gmp
DEBUG: Found Dependency: receipt exists for gmp
DEBUG: Executing org.macports.main (mpfr)
DEBUG: Skipping completed org.macports.fetch (mpfr)
DEBUG: Skipping completed org.macports.checksum (mpfr)
DEBUG: setting option extract.cmd to /usr/bin/bzip2
DEBUG: Skipping completed org.macports.extract (mpfr)
DEBUG: Skipping completed org.macports.patch (mpfr)
DEBUG: Skipping completed org.macports.configure (mpfr)
DEBUG: Skipping completed (mpfr)
DEBUG: Skipping completed org.macports.test (mpfr)

Then I tried to update the libgmp and libmpfr files in XCode's
"Link Binary With Library" and I find odd things :
- when I link with the ".a" it doesn't work properly
- when I link with the ".dylib" IT IS OK but in 2 different projects
I have two different names : libmpfr.dylib and libmpfr.1.dylib and
I do not manage to find both in the finder...

What should I use ? ".a", ".dylib" ?
Do I need to delete and add new links in XCode each time I update
the lib in MacPorts ?


Le 4 mai 2010 à 00:12, Ryan Schmidt a écrit :

> On May 3, 2010, at 14:31, Vincent DIEMUNSCH wrote:
>> I use MPFR (and therefore GMP) and when I updated them to the latest versions :
>> - GMP : 5.0.1_0
>> - MPFR : 2.4.2-p1_0
>> I get completely crazy results, like sum of 1/n! for n in 0 .. 100 = 4.5... instead of 2.71828...
>> I have update XCode to the latest version for SnowLeopard (32 bits).
>> - OS : 10.6.3
>> - XCode : 3.2.2
>> - gcc by default : i686-apple-darwin10-gcc-4.2.1
>> Note that gcc 4.3.4 is installed on MacPorts...
> Ports in MacPorts shouldn't be using any extra compilers you may have installed (except for a few select ports that explicitly request to do so). Or did you "gcc_select" it by any chance? Some ports will then mistakenly use the compiler you gcc_selected instead of the default compiler.
>> Could you help me ?
> Have you tried running these ports' test suite?
> sudo port -d test gmp
> sudo port -d test mpfr
> Do the test suites pass?

More information about the macports-users mailing list