After latest updates, Gramps crashes on startup - the problem seems to be with Platypus

David Rowe drowe at
Wed May 19 12:59:30 PDT 2010

For everyone's information:

Re my message on 18/05/2010 12:15 'After latest updates, Gramps crashes 
on startup':

    Gramps (gramps @3.2.0, Revision 1) was working OK until 18/05/2010 
    but after the latest set of MacPorts upgrades Gramps no longer
    started on my system:

    289: ERROR: line 138: Unhandled exception
    Traceback (most recent call last):
       File "/opt/local/share/gramps/", line 187, in <module>
         errors = run()
       File "/opt/local/share/gramps/", line 179, in run
         from gui.grampsgui import startgtkloop
       File "/opt/local/share/gramps/gui/", line 63, in
         import Utils
       File "/opt/local/share/gramps/", line 49, in <module>
         from GrampsLocale import codeset
       File "/opt/local/share/gramps/GrampsLocale/", line 23,
    in <module>
         from _GrampsLocale import *
       File "/opt/local/share/gramps/GrampsLocale/",
    line 137, in <module>
    unicode(time.strftime('%B',(0,1,1,1,1,1,1,1,1)),codeset).lower() : 1,
    LookupError: unknown encoding:

    When I reverted some of the upgrades:
    gettext                        0.17_4 < 0.18_0
    python26                       2.6.5_0 < 2.6.5_1
    glib2                          2.22.5_0 < 2.24.1_0
    gtk2                           2.18.8_0 < 2.20.1_0
    atk                            1.28.0_0 < 1.30.0_0

    Then Gramps worked again.

After some investigation, I think we can point the finger at a different 
piece of software:

I have let MacPorts update its ports to the latest versions - the ones I 
reported as causing the mysterious crash.
If I open up terminal and type 'gramps' (or rather 
'/opt/local/bin/gramps') then Gramps starts OK - there are no problems.

However, for convenience, I have been using a utility called Platypus 
that takes a shell script and wraps a minimal MacOS app around it so 
that you can run the script from the MacOS dock. See
The script I used was simply:


If I run this script from the terminal command line, then again Gramps 
starts OK.
However if I use Platypus to run the script, then we get the errors I 
described above. Platypus must be doing something to the environment 
that messes up Gramps when it starts.

This is all rather strange - I have been using Platypus to launch Gramps 
for over a year now and I have also been using it to launch Gnucash and 
Inkscape with no problems. Something must have happened in one of the 

    gettext @0.18_0
    python26 @2.6.5_1+darwin
    glib2 @2.24.1_0+darwin
    gtk2 @2.20.1_0+x11
    atk @1.30.0_0

to introduce a sensitivity to whatever Platypus is doing.
The obvious workround is to avoid Platypus, particularly for 
Python-based applications like Gramps

David Rowe

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list