qemu-usermode, install problems. Requires gcc 3.x

Ryan Schmidt ryandesign at macports.org
Wed Mar 2 16:14:38 PST 2011

On Mar 2, 2011, at 17:28, Fredrik wrote:

> I'm have tried to install qemu-usermode and get an error. In the log file the stated reason is: 
> :info:configure WARNING: "gcc" looks like gcc 4.x
> :info:configure Looking for gcc 3.x
> :info:configure gcc 3.x not found!
> :info:configure QEMU is known to have problems when compiled with gcc 4.x
> :info:configure It is recommended that you use gcc 3.x to build QEMU
> :info:configure To use this compiler anyway, configure with --disable-gcc-check
> Should I install gcc 3.x? If so, will I get any problems/ambiguities with using version 4.x for normal use? I would like to know if someone else have managed to install it with --disable-gcc-check and if that went well, or resolved it in some other way. 

gcc 3.x is ancient and probably does not work on current systems.

Looks like the qemu-usermode port has not been updated in awhile. Have you tried the qemu port?

More information about the macports-users mailing list