smartd automated scanning failing

Bradley Giesbrecht pixilla at
Thu Dec 4 17:54:02 PST 2014

On Dec 4, 2014, at 5:08 PM, Ubence Quevedo <thatrat at> wrote:

>> On Dec 4, 2014, at 3:46 PM, Bradley Giesbrecht <pixilla at> wrote:
>> On Nov 27, 2014, at 7:04 AM, Ubence Quevedo <thatrat at> wrote:
>>> Hi All,
>> Hi from Turlock:)
> Greetings from Merced!
>>> I'm not sure that this is the right place to post this, but it seems that smartmontools that I have installed through port isn't scanning drive when I have the appropriate configuration file at /opt/local/etc/smartd.conf configured.
>>> Here's the relevant line to run a short scan at 5AM every morning and then a long scan at 6AM:
>>> /dev/disk0 -H -l error -l selftest -f -s (S/../.././05|L/../.././06) -m xxxxxxx at
>>> I took a look at the console, and saw the following lines when the scanning was supposed to occur:
>>> Nov 25 05:22:24 Ubences-Intel-iMac.local smartd[152]: Authorization, server not available
>>> Nov 25 05:22:24 Ubences-Intel-iMac.local smartd[152]: Device: /dev/disk0, execute Short Self-Test failed.
>>> Nov 25 06:22:25 Ubences-Intel-iMac.local smartd[152]: Device: /dev/disk0, execute Long Self-Test failed.
>>> What stands out to me is the first line "Authorization, server not available".
>>> I've tried looking for info on this particular output, but I can't find anything to trace back to how this is occurring?
>> Can you run smartctl successfully?
>> sudo smartctl -P show /dev/disk0
>> sudo smartctl -t short /dev/disk0
>> sudo smartctl -a /dev/disk0
> I can run all of those, and I’ve never had to sudo them:

I didn't either but all the man/doc pages I was reading used sudo so I thought it better to add it.

What happens if you run smartd manually in debug mode and without forking:
sudo port unload smartmontools
sudo /opt/local/sbin/smartd -n -d -c /opt/local/etc/smartd.conf

When I ran manually without sudo smartd complained about not being able to write a state file to:

Bradley Giesbrecht (pixilla)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 455 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <>

More information about the macports-users mailing list