upgrade outdated fails for clang 3.6

firetiti firetiti at gmail.com
Fri Sep 25 16:43:29 PDT 2015

thank you very much for you help.
It worked to install clang, but now it is cmake that generates an issue (and I already tried to clean it without success).
See the log: www.thibault.biz/OHSU/log.log


Le 25 sept. 2015 à 16:11, Brandon Allbery <allbery.b at gmail.com> a écrit :

> On Fri, Sep 25, 2015 at 7:03 PM, firetiti <firetiti at gmail.com> wrote:
> I tried to do a « port selfudapte » followed by a « port upgrade outdated » and it failed during clang upgrade, because of a lack of space.
> Now I have plenty of space on my computer, but the « upgrade outdated » still fails for clang.
> Your log file is not from a clean build. Please "sudo port clean clang-3.6" and build again.
> That said: this does not look like out of space to me.
> :info:build ld: malformed archive TOC entry for __ZN5clang14TypeLocBuilder4pushINS_22FunctionNoProtoTypeLocEEET_NS_8QualTypeE, offset 251830784 is beyond end of file 115048448
> :info:build  file '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_llvm-3.6/clang-3.6/work/build/Release+Debug/lib/libclangSema.a' for architecture x86_64
> This is a corrupt archive. But because this was not a clean build, it is not possible to see what happened when the archive was built; the build assumed that it completed successfully and then failed when the archive was found to be invalid.
> -- 
> brandon s allbery kf8nh                               sine nomine associates
> allbery.b at gmail.com                                  ballbery at sinenomine.net
> unix, openafs, kerberos, infrastructure, xmonad        http://sinenomine.net

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.macosforge.org/pipermail/macports-users/attachments/20150925/f75db101/attachment.html>

More information about the macports-users mailing list