request assist upgrading clang

Ryan Schmidt ryandesign at
Sun Dec 24 19:44:44 UTC 2017

On Dec 24, 2017, at 11:44, Brian wrote:

> I noticed an error when I tried to run any windows executable such as  "wine explorer" from the Mac command line.    Macbook Pro running SnowLeopard 10.6.8.  
> err:module:import_dll Library ksecdd.sys (which is needed by L"C:\\windows\\System32\\DRIVERS\\ui11drdr.sys") not found
> err:winedevice:async_create_driver failed to create driver L"ui11drdr": c0000142
> So I decided to upgrade and update things.  "sudo port selfupdate" Macports selfupdated from 2.0.3 to 2.4.2 without trouble.

I'm glad you're updating! MacPorts 2.0.3 was released in 2011. You should update at least yearly, and ideally much more often than that, otherwise it may be difficult to upgrade some ports.

> Per the update script recommendation, I listed "sudo port outdated" and I get dozens of packages listed. I picked just one of the ports listed on the outdated list, "sudo port upgrade bison" and after it finished, I was able to do others also.  However after each upgrade, I got:
> --->  Scanning binaries for linking errors               
> --->  Found 4 broken files, matching files to ports      
> --->  Found 2 broken ports, determining rebuild order
> You can always run 'port rev-upgrade' again to fix errors.
> The following ports will be rebuilt:
> cmake @2.8.12+universal
> kermit @9.0.302+universal
> Continue? [Y/n]: n
> I answered "Y" to continue.  Here's what happened: 
> --->  Computing dependencies for clang-3.7
> --->  Staging clang-3.7 into destroot
> Error: Failed to destroot clang-3.7: command execution failed
> Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-3.7/clang-3.7/main.log for details.
> Error: Problem while installing clang-3.7
> Error: rev-upgrade failed: Error rebuilding cmake
> Error: Follow to report a bug.
> ..and any attempt to upgrade those two packages gives the same error.  I look into the named log and it is hundreds of lines of things I don't understand.  I tried to upgrade individual packages such as "sudo port upgrade texinfo" and it appears that two packages are stuck with the above errors:  kermit and cmake.  Those gets hung with the clang package error.
> How do I get those two fixed?

Impossible to guess why it failed without seeing the contents of the log.

First, clean the failing port and try again: "sudo port clean clang-3.7". If it fails again, please file a ticket in the issue tracker and compress and attach the main.log file to the ticket.

> Then, how do I get the original ksecdd.sys file to be found?

That I don't know.

More information about the macports-users mailing list