Compiling git

Ken Cunningham ken.cunningham.webuse at
Fri Oct 27 18:28:51 UTC 2017

Hello my friend,

The only way we would be able to help you is if you

sudo port -v install git

and then tell us what happens.

There are too many unknowns to realistically get you going with any other approach.



On 2017-10-27, at 11:21 AM, Michael wrote:

> So I'm trying to compile git from sources.
> The first thing I tried was a straight download of the raw git. No go. 
> The second thing I tried was using the macport patches (a makefile patch setting a linker flag, it looks like).
> But, attempting to compile the profiling mode fails. There does not seem to be an option in macports for working with profiling.
> Error line:
> clang: error: unknown argument: '-fprofile-generate=/Volumes/UserData/Users/michael/Documents/Programming/git'
> make[1]: *** [credential-store.o] Error 1
> make: *** [profile] Error 2
> Full log:
> Anything obvious to porters, or should I bounce this up to the git list?
> ---
> Entertaining minecraft videos

More information about the macports-users mailing list