problem installing gnureadline

Rainer Müller raimue at
Mon Apr 16 15:51:20 UTC 2018

On 2018-04-16 16:32, pagani laurent via macports-users wrote:
> Hi,
> I have python3.6 updated, and selected to run on command python3 and ipython3.
> I tried to install py36-jupyter (never installed before).
> It crashed on trying to install py36-gnureadline.
> I cleaned py36-gnureadline and tried again. Crashed again (attached the log) :
> --->  Fetching distfiles for py36-gnureadline
> --->  Verifying checksums for py36-gnureadline
> --->  Extracting py36-gnureadline
> --->  Applying patches to py36-gnureadline
> --->  Configuring py36-gnureadline
> --->  Building py36-gnureadline
> Error: Failed to build py36-gnureadline: command execution failed
> Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-gnureadline/py36-gnureadline/main.log for details.
> Error: Follow to report a bug.
> Error: Processing of port py36-gnureadline failed

This is actually a problem with a file installed by the py36-scipy port:

:info:build PermissionError: [Errno 13] Permission denied:

Note the current version of py-scipy is 1.0.1. This file or a similar
file is not part of the current py36-scipy archive.

You should upgrade the outdated ports on your system:
  sudo port selfupdate
  sudo port upgrade outdated


More information about the macports-users mailing list