problem installing gnureadline

pagani laurent laurent.pagani at
Mon Apr 16 18:07:35 UTC 2018


I just updated the outdated ports before trying to install py36-jupyter :

Macports>sudo port upgrade outdated
Nothing to upgrade.

but py36-scipy was not installed (I was on py35 until now because of the py36-readline bug).

So I installed py36-scipy but the error remains the same.
Same permission error in the logfile.


> Le 16 avr. 2018 à 17:51, Rainer Müller <raimue at> a écrit :
> On 2018-04-16 16:32, pagani laurent via macports-users wrote:
>> Hi,
>> I have python3.6 updated, and selected to run on command python3 and ipython3.
>> I tried to install py36-jupyter (never installed before).
>> It crashed on trying to install py36-gnureadline.
>> I cleaned py36-gnureadline and tried again. Crashed again (attached the log) :
>> --->  Fetching distfiles for py36-gnureadline
>> --->  Verifying checksums for py36-gnureadline
>> --->  Extracting py36-gnureadline
>> --->  Applying patches to py36-gnureadline
>> --->  Configuring py36-gnureadline
>> --->  Building py36-gnureadline
>> Error: Failed to build py36-gnureadline: command execution failed
>> Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-gnureadline/py36-gnureadline/main.log for details.
>> Error: Follow to report a bug.
>> Error: Processing of port py36-gnureadline failed
> This is actually a problem with a file installed by the py36-scipy port:
> :info:build PermissionError: [Errno 13] Permission denied:
> '/opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/scipy-0.19.1.dist-info'
> Note the current version of py-scipy is 1.0.1. This file or a similar
> file is not part of the current py36-scipy archive.
> You should upgrade the outdated ports on your system:
>  sudo port selfupdate
>  sudo port upgrade outdated
> Rainer

"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème" (devise Shadok)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: main.log
Type: application/octet-stream
Size: 56472 bytes
Desc: not available
URL: <>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list