Odd mpv configure series failure following fresh reinstall

Lee Bast x-lists at asgarda.com
Wed Jun 20 01:19:12 UTC 2018

	Just wanted to give a small follow up: in the end I think the mpv port is just entirely broken for me. I kept trying things until I ended up doing a total fresh install again following updating to Xcode 9.4. Starting entirely from scratch and just doing a plain "port install mpv" with no variants or anything else installed first I still get the exact same error where configure fails on

> :info:configure Checking for Lua                                                  : no ('lua-5.2 >= 5.2.0' not found) 

It looks like MacPorts' mpv is about a year old now so it might just be related to age, and since ticket #54867 is already accepted for updating it at some point I'm not sure if there is any point in opening a new ticket until that's done. Once it's updated maybe that'll resolve it by itself. Although Ken indicated it built, so yeah, not really sure what else to try if a clean install fails as the first port, although I'd be happy to give it a shot if there are suggestions.

Fresh install log but nothing particularly interesting I think. Also thanks again for your earlier reply Ken!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: fresh-mpv-main.log.tar.gz
Type: application/x-gzip
Size: 9878 bytes
Desc: not available
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20180619/98d87f88/attachment.bin>
-------------- next part --------------

> On Jun 9, 2018, at 0028 , Lee Bast <x-lists at asgarda.com> wrote:
> Thanks for the suggestion but no go, also the variants are a red herring and don't matter, it has the exact same build failure with a pure vanilla 'port install mpv', zero variants at all. Dies on checking for Lua, despite lua52 being a dependent that gets automatically installed first (and after trying to install mpv and checking 'port installed' it shows lua52 as active like expected, and lua5.2 is there in /opt/local/bin). Stumped, worked fine until the last upgrade. Maybe I'll spin up some VMs this weekend to play with it in.

More information about the macports-users mailing list