Odd mpv configure series failure following fresh reinstall

Rainer Müller raimue at macports.org
Wed Jun 20 14:09:19 UTC 2018

On 2018-06-20 03:19, Lee Bast wrote:
> 	Just wanted to give a small follow up: in the end I think the mpv port is just entirely broken for me. I kept trying things until I ended up doing a total fresh install again following updating to Xcode 9.4. Starting entirely from scratch and just doing a plain "port install mpv" with no variants or anything else installed first I still get the exact same error where configure fails on
>> :info:configure Checking for Lua                                                  : no ('lua-5.2 >= 5.2.0' not found) 

Just checking, is the lua52 port installed and active?

$ port installed lua52
The following ports are currently installed:
  lua52 @5.2.4_1 (active)

> It looks like MacPorts' mpv is about a year old now so it might just be related to age, and since ticket #54867 is already accepted for updating it at some point I'm not sure if there is any point in opening a new ticket until that's done. Once it's updated maybe that'll resolve it by itself. Although Ken indicated it built, so yeah, not really sure what else to try if a clean install fails as the first port, although I'd be happy to give it a shot if there are suggestions.
> Fresh install log but nothing particularly interesting I think. Also thanks again for your earlier reply Ken!

The problem can probably only be debugged further by looking into
config.log, which contains the details how and where mpv expected to
find Lua. Use this command to find this file after the failed build attempt:

$ find $(port work mpv) -name config.log

Also, to make another guess on what is going on, what is the result of
the following command on your system?

$ pkg-config --libs --cflags lua-5.2
-I/opt/local/include/lua-5.2 -L/opt/local/lib/lua-5.2 -llua-5.2 -lm


More information about the macports-users mailing list