Odd mpv configure series failure following fresh reinstall

Lee Bast x-lists at asgarda.com
Wed Jun 20 19:20:20 UTC 2018

> On Jun 20, 2018, at 1009 , Rainer Müller <raimue at macports.org> wrote:
> On 2018-06-20 03:19, Lee Bast wrote:
>> 	Just wanted to give a small follow up: in the end I think the mpv port is just entirely broken for me. I kept trying things until I ended up doing a total fresh install again following updating to Xcode 9.4. Starting entirely from scratch and just doing a plain "port install mpv" with no variants or anything else installed first I still get the exact same error where configure fails on
>>> :info:configure Checking for Lua                                                  : no ('lua-5.2 >= 5.2.0' not found) 
> Just checking, is the lua52 port installed and active?
	No, I did a total clean install blowing away everything (following https://guide.macports.org/#installing.macports.uninstalling <https://guide.macports.org/#installing.macports.uninstalling>) then tried 'port install mpv' as the very first port following self-update. lua52 is a dependency of mpv, so like any other port it's installed first along with all other not present dependencies before it finally gets to mpv right? In my first encounter (back on June 7th) of the problem if I manually installed lua then that check would pass, except that then it would immediately fail on the next dependency, and so on. I can't think of any other port where there is a need to manually install every single dependency unless the user wants a custom variant or to try to force the use of something non-default (like libressl vs openssl). I don't think lua specifically is the issue here, rather it's something in how the port is handling dependency installation, or some other interaction.

> The problem can probably only be debugged further by looking into
> config.log, which contains the details how and where mpv expected to
> find Lua. Use this command to find this file after the failed build attempt:
> $ find $(port work mpv) -name config.log
	Here you go:

At the end it says "err: Package file '/opt/local/lib/pkgconfig/lua-5.2.pc' appears to be empty", and navigating to there yeah it's 0. It actually looks like every dependency of the mpv port install is size 0:
> % gls -l --si -S
> [...]
> -rw-r--r-- 1 root     admin    0 Jan 20 09:44 dvdnav.pc
> -rw-r--r-- 1 root     admin    0 Jan 20 09:46 dvdread.pc
> -rw-r--r-- 1 root     admin    0 Sep 30  2017 libcddb.pc
> -rw-r--r-- 1 root     admin    0 Sep 30  2017 libcdio++.pc
> -rw-r--r-- 1 root     admin    0 Sep 30  2017 libcdio.pc
> -rw-r--r-- 1 root     admin    0 Sep 30  2017 libcdio_cdda.pc
> -rw-r--r-- 1 root     admin    0 Sep 30  2017 libcdio_paranoia.pc
> -rw-r--r-- 1 root     admin    0 Apr  5 20:14 libdvdcss.pc
> -rw-r--r-- 1 root     admin    0 Sep 30  2017 libiso9660++.pc
> -rw-r--r-- 1 root     admin    0 Sep 30  2017 libiso9660.pc
> -rw-r--r-- 1 root     admin    0 Sep 30  2017 libudf.pc
> -rw-r--r-- 1 root     admin    0 Sep 30  2017 lua-5.2.pc
> -rw-r--r-- 1 root     admin    0 May 26 13:41 rubberband.pc
> -rw-r--r-- 1 root     admin    0 Jun  2 11:08 sndfile.pc
At this point I've already reinstalled all my other regular ports so this list is a lot shorter then it'd be on a fresh install I assume, ffmpeg & mkvtoolnix etc already covered much of what mpv would want. Only the remaining dependencies exclusively left to mpv show size zero. I don't know what to make of that. I assume all sizes for a port installing dependencies being zero is not normal?
> Also, to make another guess on what is going on, what is the result of
> the following command on your system?
> $ pkg-config --libs --cflags lua-5.2
> -I/opt/local/include/lua-5.2 -L/opt/local/lib/lua-5.2 -llua-5.2 -lm
"Unknown option -I"

Thanks for your suggestions of something else to look at! I didn't think to look at that build config.log before vs the main log.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20180620/22945504/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: mpv-config.log
Type: application/octet-stream
Size: 84698 bytes
Desc: not available
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20180620/22945504/attachment.obj>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20180620/22945504/attachment-0001.html>

More information about the macports-users mailing list