Jeff Greenberg listmail.ayendesigns at
Sat Feb 15 14:49:11 UTC 2020

Thanks, all. I did the following, which ended up eventually resolving the problem. Just want to make sure I did this correctly and that there wasn’t just a port fubar option that would have done it :)

First I used port dependents to find what was dependent on gtk-doc. Then I did port dependents on those, and eventually found quite a few ports that nothing was dependent on, so I uinstalled them in reverse order. 

Then I finally got port upgrade outdated to run cleanly, but still no connection to localhost.

I then installed the apache2 port and reinstalled it, which completed cleanly. I received a message about enabling it for the first time, executed that command, and that went cleanly, but still no connection.

At that point, though, I could actually do a /opt/local/sbin/apachectl start and voila! A web server!!

> On Feb 15, 2020, at 9:18 AM, Ryan Schmidt <ryandesign at> wrote:
> On Feb 15, 2020, at 00:22, Jeff Greenberg wrote:
>> <main.log>
>> Hi. After restarting my mac, localhost is refusing connections, and attempting to restart apachectl results in this error message:
>> httpd: Syntax error on line 168 of /opt/local/etc/apache2/httpd.conf: Cannot load lib/apache2/modules/ into server: dlopen(/opt/local/lib/apache2/modules/, 10): Library not loaded: /opt/local/lib/libicui18n.58.dylib\n  Referenced from: /opt/local/lib/apache2/modules/\n  Reason: image not found
> This is <>
> I guess you had not updated your ports in awhile, and just now updated from icu 58 to 65. 
> Below we see that rev-upgrade has correctly detected the problem and would rebuild the affected port, were it not for the problem rebuilding gtk-doc that interrupted it. 
>> Having had this error after upgrading gimp, I tried doing what I had to do then:
>> /opt/local/bin$ sudo port upgrade icu -Rf
> You should not be attempting to force things unnecessarily. And I don't believe you're successfully forcing anything, since single-dash flags like -f and -R must be placed between the word "port" and the command verb that follows it in order to have any effect. 
>> which yields the following:
>> --->  Updating database of binaries
>> --->  Scanning binaries for linking errors
>> --->  Found 27 broken files, matching files to ports     
>> --->  Found 6 broken ports, determining rebuild order
>> You can always run 'port rev-upgrade' again to fix errors.
>> The following ports will be rebuilt:
>>  avahi @0.7+gtk+gtk3+x11
>>  graphviz @2.40.1+pangocairo+x11
>>  php72-apache2handler @7.2.16
>>  gimp2 @2.8.22+python27
>>  boost @1.66.0+no_single+no_static+python27
>>  sane-backends @1.0.27+avahi
>> Continue? [Y/n]: Y
>> --->  Building gtk-doc
>> Error: Failed to build gtk-doc: command execution failed
>> Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_gtk-doc/gtk-doc/main.log for details.
>> Error: Problem while installing gtk-doc
>> Error: rev-upgrade failed: Error rebuilding avahi
>> Error: Follow <> to report a bug.
>> The log file is attached.
> The log says the problem is:
> :info:build /opt/local/bin/ranlib: object: .libs/libtester.a(tester.o) malformed object (unknown load command 1)
> But I don't know why. Maybe you need a newer cctools and/or ld64, possibly using the xcode/ld64_xcode variant. Or maybe those ports just need to be upgraded first; I think they were just updated to new versions a few days ago. 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list