Using macports 2.6.2 on a powerbook G4 1.33GHz and Leopard 10.5.8 ppc

ggrubbish at ggrubbish at
Mon Mar 9 19:47:45 UTC 2020


I'm using since last week macports on a powerbook G4 1.33 12" aluminium.

I wanted to use gsmartcontrol, encfs and extfat for an external wd book hdd.

But I was until yet only capable to build slocate.

For gsmartcontrol I ran into issues with python38, and a very slow build process.


python38: fails on Leopard: Undefined symbols: :info:build "_pthread_threadid_np"

python38: Disable posix._fcopyfile function on Tiger #5987

python38: fix build on older systems #6492

python38: fix build on older systems

there is no copyfile on Tiger
work around lack of pthread_threadid_np on < 10.6


python38: fix build on older systems - second try #6542

gcc 7.50

Also I ran into issues with cmake/gcc7.5.0
cmake 3.16.0: does not build on PPC Mac OS X 10.5.8, "Bus Error"

I'm not sure, if I should simply wait for macports 2.6.3, or whenever the patches are updated, to solve those issues, or if I might have a chance, to cope with it by installing e.g. gcc 7.4.0 and cope with the python38 issue myself. E.g. I'm uncertain, which commit I should use to roll back gcc, because I don't have a older version installed, which would make the process much more easier to work around.


More information about the macports-users mailing list