macports-users Digest, Vol 163, Issue 12

Murray Eisenberg murrayeisenberg at
Tue Mar 17 15:04:08 UTC 2020

I did that: used mode 755 for directories, mode 644 for files there. 

Still, same error Unable to execute port: Could not open file: /Users/murray/macports/myports/kde/okular/Portfile

Did you get this to work with your own version of a port already included in MacPorts?

> On16 Mar 2020 21:13:58 +0100,Pieter van Oostrum <pieter-l at <mailto:pieter-l at>> wrote:
> Subject: Re: installing patched okular: cannot open Portfile
> Ken Cunningham <ken.cunningham.webuse at <mailto:ken.cunningham.webuse at>> writes:
>>    gives error:
>>        Unable to execute port: Could not open file: /Users/murray/macports/myports/kde/okular/Portfile
>>    Could it still be a permissions or ownership issue?
>> It is a permissions error. Although Chris and others seem to make this work, it has never worked
>> for me to put a macports repo in my home folder. I don’t know why, and I gave up trying to fix it.
>> Just put it in /Users/Shared/MacPorts or, what I do, is put them all in /opt (but then you have to
>> be careful with sudo, which I always am).
> Very strange. I have been using this construction for years. I have all my directories in my private repository with mode 755, and the files 644.
> -- 
> Pieter van Oostrum

Murray Eisenberg			murrayeisenberg at
503 King Farm Blvd #101	Home (240)-246-7240
Rockville, MD 20850-6667	Mobile (413)-427-5334

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list