macports-users Digest, Vol 163, Issue 12

Christopher Jones jonesc at
Tue Mar 17 15:15:50 UTC 2020

> On 17 Mar 2020, at 3:04 pm, Murray Eisenberg <murrayeisenberg at> wrote:
> I did that: used mode 755 for directories, mode 644 for files there. 
> Still, same error Unable to execute port: Could not open file: /Users/murray/macports/myports/kde/okular/Portfile
> Did you get this to work with your own version of a port already included in MacPorts?

Yes. My primary (only) ports tree is a clone of the git repo. in a sub-directory of my home area.

Oberon ~/Projects > ls -lth         
total 0
drwxr-xr-x   8 chris  staff   256B  8 Oct 22:01 MacPorts

Oberon ~/Projects > cd MacPorts 

Oberon ~/Projects/MacPorts > ls -lth    
total 0
drwxr-xr-x  64 chris  staff   2.0K 17 Mar 14:42 ports
drwxr-xr-x  30 chris  staff   960B 10 Oct 10:09 base
drwxr-xr-x   5 chris  staff   160B  8 Oct 22:03 info
drwxr-xr-x  12 chris  staff   384B 11 Aug  2019 legacy-support
drwxr-xr-x  10 chris  staff   320B 15 Nov  2018 guide

Oberon ~/Projects/MacPorts > ls -lth ports/science/root6/Portfile 
-rw-r--r--  1 chris  staff    23K 17 Mar 14:43 ports/science/root6/Portfile

Oberon ~/Projects/MacPorts > cat /opt/local/etc/macports/sources.conf
# MacPorts system-wide configuration file for ports tree sources.
#rsync:// [default]
file:///Users/chris/Projects/MacPorts/ports [default]

Works just fine. e.g.

Oberon ~/Projects/MacPorts > sudo port -d sync
DEBUG: Copying /Users/chris/Library/Preferences/ to /opt/local/var/macports/home/Library/Preferences
--->  Updating the ports tree
Synchronizing local ports tree from file:///Users/chris/Projects/MacPorts/ports
DEBUG: euid/egid changed to: 501/20, env: HOME=/Users/chris SSH_AUTH_SOCK=/private/tmp/
DEBUG: /opt/local/bin/git pull --rebase --autostash
DEBUG: system -W /Users/chris/Projects/MacPorts/ports: /opt/local/bin/git pull --rebase --autostash
Created autostash: f6afbb3fb96
Current branch master is up to date.
Applied autostash.
DEBUG: euid/egid restored to: 0/0, env restored
DEBUG: system: /opt/local/bin/portindex /Users/chris/Projects/MacPorts/ports
Creating port index in /Users/chris/Projects/MacPorts/ports
Adding port science/root6

Total number of ports parsed:	1 
Ports successfully parsed:	1 
Ports failed:			0 
Up-to-date ports skipped:	23266

I can edit, maintain, interact with git,  the ports under ~/Projects/Macports/ports using my regular user account, no sudo required.

Oberon ~/Projects/MacPorts/ports > git status
On branch master
Your branch is up to date with 'origin/master'.

Changes not staged for commit:
  (use "git add <file>..." to update what will be committed)
  (use "git restore <file>..." to discard changes in working directory)
	modified:   science/root6/Portfile

no changes added to commit (use "git add" and/or "git commit -a")

>> On16 Mar 2020 21:13:58 +0100,Pieter van Oostrum <pieter-l at <mailto:pieter-l at>> wrote:
>> Subject: Re: installing patched okular: cannot open Portfile
>> Ken Cunningham <ken.cunningham.webuse at <mailto:ken.cunningham.webuse at>> writes:
>>>    gives error:
>>>        Unable to execute port: Could not open file: /Users/murray/macports/myports/kde/okular/Portfile
>>>    Could it still be a permissions or ownership issue?
>>> It is a permissions error. Although Chris and others seem to make this work, it has never worked
>>> for me to put a macports repo in my home folder. I don’t know why, and I gave up trying to fix it.
>>> Just put it in /Users/Shared/MacPorts or, what I do, is put them all in /opt (but then you have to
>>> be careful with sudo, which I always am).
>> Very strange. I have been using this construction for years. I have all my directories in my private repository with mode 755, and the files 644.
>> -- 
>> Pieter van Oostrum
> ---
> Murray Eisenberg			murrayeisenberg at <mailto:murrayeisenberg at>
> 503 King Farm Blvd #101	Home (240)-246-7240
> Rockville, MD 20850-6667	Mobile (413)-427-5334

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 1930 bytes
Desc: not available
URL: <>

More information about the macports-users mailing list