Error: Failed to build source-highlight: command execution failed

tom eee eeetom87 at
Wed May 5 17:19:16 UTC 2021

First, thank you all for your help, especially Ken Cunningham for the tip
on legacy Chrome (installed and working well!!!).

Second, I retried 'sudo port install source-light' with no success.  The
main.log was very big, so I cut out a big portion of the middle and
attached it to this email.

Third, I downloaded Xcode 4.6.3 and when the opened dmg directed me to
install the Xcode in my Application folder, I checked for what was already
there first, only to discover that I had Xcode 4.6.3 installed in the
Application folder since 2013!  I then looked in the Developer folder and
discovered Xcode 4.2 was there.  So I am confused about how to make Xcode
4.6.3 the version that MacPorts sees when it is doing it's thing and do I
now have to do some update for Developer?

Thank you,

On Sat, May 1, 2021 at 12:59 PM Ryan Schmidt <ryandesign at>

> On Apr 30, 2021, at 18:11, tom eee wrote:
> > I did as you suggested and after a lengthy period of time I got the
> following:
> >
> > Error: On macOS 10.7, libsdl2 @2.0.14 requires Xcode 4.3 or later but
> you have Xcode 4.2.
> > Error: See for
> download links.
> > Error: Failed to extract libsdl2: incompatible Xcode version
> > Error: See
> /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_libsdl2/libsdl2/main.log
> for details.
> > Error: rev-upgrade failed: Error rebuilding ffmpeg
> We have a binary of libsdl2 @2.0.14 for all systems, including Mac OS X
> 10.7, so I'm not sure why your MacPorts was unable to obtain this from us
> and tried instead to build it from source.
> libsdl2 and ffmpeg (graphics and video libraries, respectively) have
> nothing to do with clang (a compiler). Trying to reinstall clang-9.0 should
> not have involved trying to install libsdl2 or ffmpeg. My guess is that
> reinstalling clang-9.0 succeeded and then MacPorts ran its rev-upgrade
> process to see if any installed ports were broken (I see "rev-upgrade
> failed" in your output above), and found that ffmpeg and libsdl2 were
> broken and tried to rebuild them, which failed. But if clang-9.0 was
> successfully reinstalled, you could now try again to install
> source-highlight using clang-9.0.
> > I went to Apple Developer to get Xcode 4.3 and the log in screen just
> spins at me after entering my id and password.
> > So I guess I am just hosed until I can figure out how to get Xcode 4.3.
> It would not be surprising for you to be unable to connect to or interact
> with modern web sites using a web browser that works on Mac OS X 10.7,
> since that is so old. If you have a computer running a newer OS, you could
> download a newer Xcode there and transfer it to this computer.
> It is probably a good idea to update to Xcode 4.6.3 as soon as possible,
> so that any other builds you need to do on your system use the same
> compiler we've tested with so that you don't run into other problems we
> haven't seen before.
> > I do not really understand all of this and how it all fits together, the
> best I can do is just keep going until I run out of windmills to tilt.  Is
> there any value to just erasing everything and starting over?
> Erasing MacPorts won't update your Xcode for you, which is what you need
> to do to overcome the current issue.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: source-highlight-main.log
Type: application/octet-stream
Size: 154856 bytes
Desc: not available
URL: <>

More information about the macports-users mailing list