Error with 'port -vst install'

Pieter van Oostrum pieter-l at
Mon Oct 10 13:16:50 UTC 2022

Clemens Lang <cal at> writes:

> Hi,
> On Fri, Oct 07, 2022 at 09:16:50PM +0200, Pieter van Oostrum wrote:
>> Although your suggestion solved the problem for me, I have another
>> followup.
>> I found this ticket, which describes the same problem:
>> It is six years old and it is
>> marked as fixed, but now it seems to have cropped up again. Some kind
>> of regression, maybe?
> Thanks for checking, but I can't see a regression here. The MacPorts
> port still has destroot.keepdirs set for this directory, and I confirmed
> that the MacPorts 2.7.2 package for Monterey contains the directory with
> the expected permissions.
> I'm not sure why they were not correct on your system, but it doesn't
> seem to be caused by something that's very common.

I did some tests:

1) I moved /opt/local/var/macports/sip-workaround out of the way and then ran
    sudo port -f selfupdate --no-sync
    This reinstalled the macports base and a new sip-workaround was created with permissions 777.
    So far so good.
2) When I had already a sip-workaround with the wrong permissions (e.g.755), and I run then
   sudo port -f selfupdate --no-sync
   the permissions of sip-workaround are not changed.
   So if you had once installed a macports base that had the bug I
   mentioned, and a sip-workaround with default permissions had been
   created later, you're stuck with it. I suppose this is what had
   happened on my machine. This looks like a kind of bug to me.
Pieter van Oostrum <pieter at>
PGP key: [8DAE142BE17999C4]

More information about the macports-users mailing list