gcc7 not compiling on PPC due to mismatch

Riccardo Mottola riccardo.mottola at libero.it
Sun Mar 29 22:04:08 UTC 2020


Riccardo Mottola via macports-users wrote:
> actually, I was able to compile gcc7 these past two days.
> It is gcc6 that was failing, I did not have gcc7 installed.
> I will not "retry" rebuild gcc6... and in case drop it and see if we can 
> do everything without.

Got it!

so, interesting. I had obsolete gcc6.5 and obsolete libgcc7
I repeatedly tried upgrading this route.

gcc 6.5 would build wrong, stage comparion failure. THis lasted for months!

I attempted differenlty I build gcc7 (actually from your repository, I 
don't know if it matters). This gave me automatically also an up-to-date 
libgcc based on libgcc7. It Built at the first attempt

Then I tried (after a clean) rebuilding gcc 6.5 and it landed too!

This took several days.. on a 2x 1GHz G4 ! wow

And now, I am upgrading the rest and it is churing one package after the 
other, let's see where it goes undisturbed!


More information about the macports-users mailing list